+ Reply to Thread
Results 1 to 2 of 2

Thread: Prizm 2 HUD problem

  1. #1
    RBW Member UdiFreeze is an unknown quantity at this point UdiFreeze's Avatar
    Join Date
    May 2014
    Location
    Israel
    Posts
    2
    JJ-CCR

    Prizm 2 HUD problem

    Hi everyone,
    I am trying to investigate a problem with the HUD of the Prizm, would love to know if someone else are experiencing the same thing or got hollis to fix it.
    We are experiencing it with 3 units we have around here, contacted Hollis numerous times but to no avail. The heads travelled to the states and back only to return with the same problem.

    The issue is easy to explain: 15-30 minutes into the dive the HUD shuts off, after pressing the button underwater it comes back and stays on for another 15 minutes etc...
    We are experiencing this problem at various depths and consistently every dive, we are diving in salt water 100% of our dives, the units worked at least 100 hours and was purchased around 3 years ago.

    It's impossible to regenerate this problem when the unit is dry or by submerging the HUD in a glass of water, seems like pressure has something to do with it.
    Last edited by UdiFreeze; 18th March 2017 at 22:35.

  2. #2
    rEvoooooo JoeHuaSEALs is an unknown quantity at this point JoeHuaSEALs's Avatar
    Join Date
    Aug 2015
    Location
    Portland
    Posts
    48
    Prism II , LAR V , OMG C96,

    Revo Micro III

    Re: Prizm 2 HUD problem

    Quote Originally Posted by UdiFreeze  View Original Post
    Hi everyone,
    I am trying to investigate a problem with the HUD of the Prizm, would love to know if someone else are experiencing the same thing or got hollis to fix it.
    We are experiencing it with 3 units we have around here, contacted Hollis numerous times but to no avail. The heads travelled to the states and back only to return with the same problem.

    The issue is easy to explain: 15-30 minutes into the dive the HUD shuts off, after pressing the button underwater it comes back and stays on for another 15 minutes etc...
    We are experiencing this problem at various depths and consistently every dive, we are diving in salt water 100% of our dives, the units worked at least 100 hours and was purchased around 3 years ago.

    It's impossible to regenerate this problem when the unit is dry or by submerging the HUD in a glass of water, seems like pressure has something to do with it.
    do you have the first generation of Prism 2 (shearwater predator)or the second generation(petrel 2) ? send hollis an email they are very helpful, they have replied my email. You can also message them on Facebook they reply 100%. it is best to call them , the US headquarter, I have always got answer the phone in my experience.
    Last edited by JoeHuaSEALs; 19th March 2017 at 06:44.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts