+ Reply to Thread
Results 1 to 3 of 3

Thread: Liberty CCR IBOV Issues

  1. #1
    RBW Member varnesj21 is an unknown quantity at this point varnesj21's Avatar
    Join Date
    Oct 2017
    Location
    Tallahasse FL
    Posts
    2
    CCR Liberty

    Liberty CCR IBOV Issues

    I'm a Liberty CCR diver, and I use the BMCL/IBOV setup. I have found an issue with the O2 MAV. Whenever I inject O2 into my loop water leaks into the loop. Upon further investigation I discovered that the port in the loop where the o2 is being delivered is directly below the mushroom valve. So anytime I inject O2 the mushroom valve is displaced allowing water to seep into the loop. Has anyone else experienced this, and have you heard of any solutions. Thanks

  2. #2
    RBW Member DaleHawerchuck is an unknown quantity at this point DaleHawerchuck's Avatar
    Join Date
    Oct 2014
    Location
    Sherbrooke, QC
    Posts
    26
    HammerHead CCR

    Re: Liberty CCR IBOV Issues

    I don't dive a Liberty myself, but two of my close friends, including a new instructor on the unit, are using the iBOV. They both (independently) described to me the same issue..

    Sent from my SM-G930W8 using Tapatalk

  3. #3
    RBW Member varnesj21 is an unknown quantity at this point varnesj21's Avatar
    Join Date
    Oct 2017
    Location
    Tallahasse FL
    Posts
    2
    CCR Liberty

    Re: Liberty CCR IBOV Issues

    If they moved the port over a 1/2 inch then it wouldn't be directly below the mushroom valve. I've expressed my concern to divesoft, but they haven't gotten back to me.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts