+ Reply to Thread
Results 1 to 6 of 6

Thread: RMS shearwater wont see cells

  1. #1
    RBW Member Agent 47 is on a distinguished road Agent 47 is on a distinguished road Agent 47's Avatar
    Join Date
    Oct 2010
    Location
    Washington USA
    Posts
    122
    rEvo 3 mini RMS

    Megladon

    RMS shearwater wont see cells

    So I have been on open circuit for the last month (teaching baby divers) and just went to do a CCR dive today. The unit has been stored open with the canisters removed and the electronics sitting inside like always and worked perfectly on the last dive. Went to turn it on and found the shearwater completely dead. Replaced the battery and got low Ext battery warning along with voting fail and cells not connected. Replaced the Ext battery and now it doesn't read the battery at all and still will not read any cells, says "no Connection" checked the two QD cable connectors and they are secure and clean. any ideas, Or did my RMS just shit the bed?

  2. #2
    Christian Rasmussen depth is just really nice depth is just really nice depth is just really nice depth is just really nice depth is just really nice depth is just really nice depth is just really nice depth is just really nice depth is just really nice depth's Avatar
    Join Date
    Aug 2006
    Location
    Denmark
    Posts
    1,022

    Re: RMS shearwater wont see cells

    Did you try contacting the manufacturer?

    Hope it is solved fast....

    /Christian
    Come to the darkside.... we have cookies...

  3. #3
    RBW Member fishb0y is an unknown quantity at this point fishb0y's Avatar
    Join Date
    Jul 2007
    Location
    Washington State
    Posts
    36
    rEvo III hCCR

    Drager Dolphin

    Re: RMS shearwater wont see cells

    Sounds like it. I had a similar issue with my inhale scrubber monitor. Its a 2 minute fix when you get the replacement part.

  4. #4
    RBW Member Sambo is an unknown quantity at this point Sambo's Avatar
    Join Date
    Jul 2008
    Location
    Cairns
    Posts
    56
    rEvo Micro FT

    Re: RMS shearwater wont see cells

    On the shearwater page go to the Bus devices page that shows all the devices. Check if any devices are showing up. Should see shearwater, O2 Board, Sol Board and Battery. If you cant see any except shearwater unplug wet connect to solenoid board, turn on shearwater and check you can now see everything else on the Bus Devices page. If you can it is your solenoid board that is faulty. Leave it unplugged as it will drain both the battery in the shearwater and the 9v battery in the box.

    If this does not work do the same with your 02 board, disconnect and check if the other devices come back on the Bus Devices page. This will show where the problem is and then just email Paul and he will send you a replacement board.

  5. #5
    RBW Member Agent 47 is on a distinguished road Agent 47 is on a distinguished road Agent 47's Avatar
    Join Date
    Oct 2010
    Location
    Washington USA
    Posts
    122
    rEvo 3 mini RMS

    Megladon

    Re: RMS shearwater wont see cells

    Quote Originally Posted by Sambo  View Original Post
    On the shearwater page go to the Bus devices page that shows all the devices. Check if any devices are showing up. Should see shearwater, O2 Board, Sol Board and Battery. If you cant see any except shearwater unplug wet connect to solenoid board, turn on shearwater and check you can now see everything else on the Bus Devices page. If you can it is your solenoid board that is faulty. Leave it unplugged as it will drain both the battery in the shearwater and the 9v battery in the box.

    If this does not work do the same with your 02 board, disconnect and check if the other devices come back on the Bus Devices page. This will show where the problem is and then just email Paul and he will send you a replacement board.
    Thanks, Ill give that a try.

  6. #6
    RBW Member Agent 47 is on a distinguished road Agent 47 is on a distinguished road Agent 47's Avatar
    Join Date
    Oct 2010
    Location
    Washington USA
    Posts
    122
    rEvo 3 mini RMS

    Megladon

    Re: RMS shearwater wont see cells

    Looks like its the O2 Board. Time to call Jason.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts